ImageMagick suggested compile options

These options were used to compile ImageMagick 6.7.9-3 and 6.8.0-4.

Before compiling, I urge you to ensure libjasper-dev is installed, so that you can manipulate JPEG2000 images. Try typing:
sudo apt-get install libjasper-dev libpng-dev

Then, type:

./configure --with-modules --with-gslib --with-wmf --with-perl --with-rsvg --with-gvc

Note: you can add HDRI http://www.imagemagick.org/script/high-dynamic-range.php
by adding this option above:
--enable-hdri

Note: To see if those options actually work, scroll back up about halfway through the console output to see if the compiler could find the modules you’re interested in. Otherwise, you won’t actually have the requested features.

Then do the usual
make
make install

Note: if you get an error like:

libMagickCore.so.6: cannot open shared object file: No such file or directory
when trying to run ImageMagick, try:

whereis libMagickCore.so.6
assuming you find it in /usr/local/lib, type:
sudo ldconfig /usr/local/lib